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USING ARCGIS TO CONSTRUCT & 
MANIPULATE DEMS 

Tutorial1

Updated:  August 6, 2010 

 Produced by Joe Wheaton 

PURPOSE 

This exercise is intended to teach you how to a) build a digital elevation model (DEM) from raw 
topogarphic point (x,y,z) data, and b) construct a DEM for a design. A small reach of the Provo River 
outside of Heber City, UT is used as an example. 

 BACKGROUND 

There are many programs you can use to construct and manipulate digital elevation models (DEMs) in. 
Most of these fall under GIS (e.g. ArcGIS, MapInfo, MapWindow), CAD  (e.g. AutoCAD) or scientific 
visualization software (e.g. Surfer, Matlab). In this exercise, we use one of the most common GIS 
programs, ArcGIS, to illustrate the workflow. In general, CAD programs tend to be much more powerful 
for drawing and design work, but limited for analyses. By contrast, drawing (referred to as editing in GIS) 
is rather cumbersome in GIS software, but analysis and display options are much richer.  

There are many uses of DEMs in restoration design including:  

• Planning Maps 
• Grading Plans (calculation of earthwork volumes) 
• Monitoring (repeat surveys for change detection and morphological sediment budgeting) 
• Boundary conditions to hydraulic and morphodynamic models 
• Visualization tool 
• Derive habitat maps, and geomorphic maps from 
• Morphometric Analyses 

For more information, see lecture slides. This tutorial is intended as a reference to remind you how to 
undertake these basic tasks, with step-by-step instructions and screen shots. 

                                                                 

1  For color version of this handout, with active hyperlinks, see: 
http://www.gis.usu.edu/~jwheaton/ICRRR/2010/Part_II/ICRRR_D2_Topo_Excercise.pdf  

http://www.gis.usu.edu/~jwheaton/ICRRR/2010/Part_II/ICRRR_D2_Topo_Excercise.pdf�
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PREREQUISITES 

• You will need the data from D2_DEM.zip2

• You will need ArcGIS 9.3.1 with the Spatial Analyst & 3D Analyst Extensions installed and 
enabled (Tools -> Extension) and the toolbars turned on (Student Version of Software available 
for free from instructors, but may not be used for business purposes). 

 unzipped to a known location (using foldernames). 

PART I – BUILD DEM 

The first part of this exercise focuses on how to build a digital elevation model (DEM) from raw survey 
data. 

LOOK AT AND PREPARE RAW X-Y-Z SURVEY DATA 

1. Navigate to the folder with your raw survey data in it and open the file in any text editor (e.g. 
wordpad or notepad). For our example, look at st_reach_topo_nez.txt (You can use the 
right-click -> Open With… -> Wordpad to do this).  

 
 

2. Notice that in this example, there appears to be a one line header (indicating here the number of 
points in the data file). Each point in the data file gives the coordinates of the point as a triplet. 
Ideally, you have some sort of metadata associated with the file to tell you what the format is, 

                                                                 

2  Tutorial data (including raw topography and aerial imagery) can be downloaded from: 
http://www.gis.usu.edu/~jwheaton/ICRRR/2010/Part_II/ProvoTopoData.zip  

http://www.gis.usu.edu/~jwheaton/ICRRR/2010/Part_II/ProvoTopoData.zip�
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where it came from, when it was collected, by what technique and by whom, as well as 
information on the coordinate system/projection. For this example, we know the file is in a nez 
format (easting, northing, elevation). Other common formats include pnezd, penzd, enz, xyz, etc. 
(where p refers to point, d refers to description, etc.). In order to import the data into ArcGIS the 
headerline is essential. Close the wordpad document and reopen the file in Excel. 

3.  In excel, all the data will be in one column. Highlight column A, by clicking on it, and then go to 
the Data menu: 

 
4. Use the Text to Columns command: 

 
Select, delimited in the first step, 
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Select, space in the next step, then Finish. This sorts the data into separate columns. 

5. Next replace the first row with easting for column A, northing for column B, and elevation for 
column C. A header is necessary to facilitate the import of the data into ArcGIS. It is critical that 
there are no spaces or special characters in the individual columns:  

 
6. Finally, using the Save As command, save the file as CSV (Comma delimited) (*.csv) file in 

the same folder (i.e. st_reach_topo_nez.csv). Click Yes when asked about the format 
warning. Quit Excel (click No to save the file as you’ve already done this). 



ICRRR Short Course Part II – DEM Exercise 

 
5 of 43 

 

IMPORT X-Y-Z DATA 

1. Open a blank new Map Document in ArcGIS3

2. Use the Tools-> Add X-Y Data command to add the st_reach_topo_nez.csv file. In the 
Add XY Data dialog, use the open folder button to bring up the st_reach_topo_nez.csv. 
Then choose the Easting field for the X-Field and Northing for the Y-Field.  

.  

 
For the Coordinate System, we know this is in UTM Zone 12, NAD 1983.  Click on Edit… and then 
in the Spatial Reference Properties Dialog, click on Select to Browse for the Coordinate 
System. Browse to Coordinate Systems -> Projected Coordinate Systems -> 
UTM -> NAD 1983 and then select  NAD 1983 UTM Zone 12N.prj.  

                                                                 

3 This tutorial was written based on ArcGIS 9.3.1. Instructions will be similar for ArcGIS 9.1 and 9.2, with 
some minor differences. Instructions for ArcGIS 10 follow a conceptually similar workflow, but some of 
the menus, command windows, and where things are accessed has changed. 
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Click on OK, then OK, then OK. Your Add XY Data dialog should look like this before clicking OK: 

 
3. This will add the raw point survey data to the map’s data frame:  
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4. Next, convert the *.csv file to a shapefile by right clicking on the st_reach_topo_nez.csv 
Events layer and going to Data -> Export Data. Navigate using the open folder button to your 
working folder and save the shape file as st_reach_topo_nez.shp. Click Yes, when asked if 
you want to add the exported data to the map as a layer.  
 

 
 

5. Remove the st_reach_topo_nez.csv Events layer from the data frame by right-clicking 
on it and selecting Remove. 

6. For context, it is sometimes helpful to see where these points reside with an aerial photo (if 
available). One was provided for you in the zip file (q1523_nw_NAIP2009.tif) as well as its 
associated files that define its projection, its position, resolution, etc. Add 

q1523_nw_NAIP2009.tif to the data frame using the Add Data   button. Make sure it 
is below the st_reach_topo_nez layer so you can see the points over the aerial photo:  
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You can turn the layer off if you don’t want to view it. 
 

7. Next save the Map Document by using the File -> Save As command. I would suggest saving the 
map document in the same folder you are working in as something logical (e.g. Provo DEM 
Exercise). 

CREATE TIN FROM DATA 

NOTE: Before creating a TIN, you need to make sure your 3D Analyst Extension is installed, enabled and 
the toolbar on. Check that the extension is enabled by using the Tools ->  Extensions and verifying it is 
checked. Check that the toolbar is loaded by right-clicking in a blank space on the toolbar and checking 
that 3D Analyst is checked. 

1. Go the the 3D Analyst Menu in the 3D Analyst Toolbar and Create/Modify TIN -> Create TIN 
from Features. 

  
This brings up a Crate TIN From Features dialog:  
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Check the st_reach_topo_nez layer and make sure the Height Source is specified as 
Elevation and Trinagulate as: is specified as Mass Points. Save the Output TIN to your working 
directory as Provo_TIN. Click OK. 

2. This produces a TIN: 

 

CHECK TIN FOR ERRORS 

Although building a TIN is easy, it is also easy to build a TIN that misrepresents your data and or has busts 
in the data. In this example the flow direction is southwest (from the upper right to lower left). 
Accordingly, the highest bed elevations are at the top of the reach and lowest are at the bottom of the 
reach. 
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1. To inspect the TIN to see if represents your data appropriately, drag your points on top of the TIN 
in the Display dock to change the display order.  

 
Notice the areas circled in red above (not shown in your display). The TIN algorithm has 
interpolated across these areas of the floodplain where no survey data was collected, by simply 
connecting the dots between the closest points. Although this may be a crude approximation of 
the floodplain surface in flat areas, it is NOT an accurate or honest representation of the survey 
data. This typically occurs with TINing in areas that represent planform concavities.  

2. Zoom into the bottom of the reach (lower left).  
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Notice the five trenches in the data. Although it is plausible that the river really does look like this 
(i.e. if a backhoe dug trenches parallel to each other and perpendicular to the river), the fact that 
these transects line up perfectly with the second, fourth, seventh, and ninth cross section 
transects in this tightly spaced cross sectional topographic survey is highly suspect. 

3. Zoom into the top of the reach (upper right).  

 
Notice that there is a wall or dam of topography preventing entry into the top of the reach. This 
is due to the two outermost points being linearly interpolated across. This is not only incorrect, 
this could seriously impact a hydraulic model’s results. 

4. We should modify the TIN to not interpolate across areas of the floodplain without data, and to 
remove these apparent busts. 

MODIFY TIN  

1. First, edit the st_reach_topo_nez shapefile to remove the points comprising the trench 
busts in the second, fourth, seventh and ninth cross sections from the left. To do this, load the 
Editor toolbar by right clicking on an empty toolbar space and checking Editor. Go to the Editor 
menu and select Start Editing. Make sure that the Target in the editor toolbar is the 
st_reach_topo_nez shapefile:  
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2. Using the edit tool  (selected in screen shot above), zoom in  and select  ONLY 
the points in the suspect transects (you can use the shift key to select multiple points at once as 
well as dragging a window box over the points you wish to select). As you select points you, you 
can right click on the selection at any time and use the delete command to delete them. When 
you are done deleting all the suspect points, navigate back to the editor menu and click on Stop 
Editing, and select YES when asked Do you want to save your edits. Your modified shape file 
should look something like this in the area of the downstream reach after editing: 

 
3. Next, we will draw a polygon around the survey data to use in the TIN construction to prevent 

interpolation outside the survey area. To do this, we first need to create a new shapefile of type 

polygon first. From the Window Menu Select the ArcToolBox  if it is not already loaded.  
Navigate in the toolbox to Data Management Tools -> Feature Class -> Create Feature 
Class: 
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For Feature Class Location, select the same working folder you’ve been using all along. For 
Feature Class Name, use Survey_Bndy. For the Geometry Type, slect Polygon. Scroll 
down and specify NAD_19883_UTM_Zone_12N as the  Coordinate System (you can use the 
import feature and import the coordinate system from your other shapefile if you wish). Click OK 
and this will create a blank shapefile. 

4. Remove the Provo_TIN from the data frame by right-clicking on it and using the Remove 
command. This will make it easier to see the survey points and enable us to overwrite the TIN 
later. Right click on the st_reach_topo_enz file and use the Zoom to Layer command. 

5. Begin an edit session for the Survey_Bndy shapefile by using the Editor -> Start Edit command 
and selecting Survey_Bndy as the 
target in the toolbar. Make sure the 
task is set to Create New Feature4

                                                                 

4 Note, if the tools are grayed out it typically means that you either not in an active edit session (i.e. you 
need to Start Editing) or that the Task is not on Create New Feature (e.g. switched to Modify Existing 
Features). 

.  

Using the pencil  (Sketch Tool) in 
the Editor toobar draw a polygon 
around the survey points such that all 
the points are inside the polygon. 
Make sure that you draw the polygon 
for the upstream boundary to prevent 
it from interpolated between the two 
outermost points and building a dam: 
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My polygon had between 25-30 vertices, use F2 to Finish the Sketch:  

 
 

6. To finish editing your polygon, Use the Editor -> Stop Editing command and save your changes. 
We are now ready to build a new TIN using our modified point file (st_reach_topo_enz) and 
our new boundary polygon (Survey_Bndy). 
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7. Go the the 3D Analyst Menu in the 3D Analyst Toolbar and Create/Modify TIN -> Create TIN 
from Features. This brings up a Create TIN From Features dialog:  

 
Again check the st_reach_topo_nez layer and make sure the Height Source is specified 
as Elevation and Trinagulate as: is specified as Mass Points.  Then click on the 
Survey_Bndy and click it too. For this one, make sure the the Height Source is specified as 
<None> and Trinagulate as: is specified as hard clip.  Save the Output TIN to your working 
directory as Provo_TIN  to overwrite the original TIN. Click OK. Then click Yes to overwrite 
the original output.  

8. This TIN looks like a much better representation of the data and does not have the obvious busts 
(trenches).  
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EXPORT UPDATED TOPOGRAPHIC POINT DATA (OPTIONAL) 

You may wish to export the modified point data5

1. Right click on the st_reach_topo_nez and select Open Attribute Table. 

 we ended up with in the st_reach_topo_nez 
shapefile. There are various ways to do this. One option is: 

2. Click on Options -> Select All 

  

3. Click on Options -> Export…  

                                                                 

5 Note, that although this method of exporting data to a table will work for any shapefile, not all 
shapefiles have coordinate fields in them (which is what we want). Look at how to create fields 
(http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Adding_and_deleting_fields ) and 
calculate geometry 
(http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=750&pid=745&topicname=Making_field_calcul
ations ) in ArcGIS Help. 

http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Adding_and_deleting_fields�
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=750&pid=745&topicname=Making_field_calculations�
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=750&pid=745&topicname=Making_field_calculations�
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This will allow you to export the data to a table (saved as a database file *.dbf). The *.dbf 
can be opened in excel and saved to any file format you wish (for example for use in a hydraulic 
model). 
 

DERIVING CROSS SECTIONS OR PROFILES FROM TIN - OPTIONAL  

One very useful feature of having a digital elevation model or TIN is to be able to derive cross sections or 
longitudinal profiles from it.  

1. In the 3D Analyst toolbar, select the TIN as the Layer and then click on the Interpolate Line  
button. Draw a line across the channel as a cross section or along the thalweg (double click to 
end the line). 

2. Once you’re happy with your line, click on the Create Profile Graph  button. This brings up 
a profile dialog showing the transect.  

 
You can modify its appearance, or export the data, or save an image of this by right-clicking on 
the graph. Refer 
to: http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=3583&pid=3577&topicname=Creati
ng_profile_graphs for more information. You can overlay two profiles by using the shift key 
before making the profile.  

http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=3583&pid=3577&topicname=Creating_profile_graphs�
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=3583&pid=3577&topicname=Creating_profile_graphs�
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There are other useful profile and cross section tools available as plug-ins to ArcGIS. For example River 
Bathymetry Toolkit (http://www.fs.fed.us/rm/boise/AWAE/projects/river_bathymetry_toolkit.shtml) and 
HEC-Geo-RAS (http://www.hec.usace.army.mil/software/hec-ras/hec-georas.html) both have a wide 
array of more powerful profiling tools. 

 

CONVERT TIN TO DEM 

A TIN is a triangular irregular network, and is one way to digitally represent 2.5D surfaces. Many programs 
require terrain to be represented in a raster format, which is a uniformly gridded representation of the 
data at some particular resolution. Since it easier to write algorithms and codes for doing analyses of 
raster data, you will find many more tools available for analyzing DEMs then TINs.  

To convert your TIN to a DEM, simply go the 3D Analyst menu -> Conversion -> TIN to Raster… 

 

Make sure the Input Tin is provo_tin, the attribute is Elevation, the Z Factor is 1.000 and the Cell 
Size is 1 meter. Save this as provo_dem in your working directory. This produces a one meter resolution 
raster:  

http://www.fs.fed.us/rm/boise/AWAE/projects/river_bathymetry_toolkit.shtml�
http://www.hec.usace.army.mil/software/hec-ras/hec-georas.html�
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DERIVE OTHER SURFACES FROM DEM 

As mentioned above, there are many commands and tools available to analyze and visualize DEMs. Here 
are some of the more common tools available to you in 3D Analyst. 

 

 

 

HILLSHADE 

A hillshade is the illumination of a surface based on the topography and a hypothetical light source.  
Hillshades are commonly used to visualize topography and terrain. Hillshades are often used as a 
contextual backdrop. 

1. To create a Hillshade of the DEM, access the Hillshade tool from 3D Analyst -> Surface 
Analysis -> Hillshade 
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.  
Make the Input Surface the Provo_DEM, use the default Azimuth and Altitude, click on the 
Model Shadows box, and leave the Z Factor as 1 and the Output Cell Size the same as the 
input raster (1 meter in our example). Click on the open folder button to specify the output 
hillshade raster name (call it Provo_HS and put it in your working directory). Click OK and wait 
patiently while the hillshade is computed. It will look something like this:  

 
2. To visualize the DEM and the hillshade together, move the Provo_HS layer beneath the 

Provo_DEM layer in the Display Dock for the data frame. Right Click on the properties of the 
DEM (Provo_DEM) and go to the symbology tab:  
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Change the symbology color ramp to something that appeals to you. 

3. Switch to the Display tab and change the transparency settings to 40%: 

 
Click OK. You can now see the hillshade beneath the DEM:  
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CONTOURS 

Contours are a useful way of visualizing topography. Contours can be derived from TINs or DEMs. 
See http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=3579&pid=3577&topicname=Creating_cont
ours for more information on creating contours. 

1. To derive contours for the Provo_DEM, go to 3D Analyst -> Surface Analysis -> Contour..:  

 
Specify Provo_DEM as the Input Surface, choose a Contour Interval (0.25 for 25 cm), leave 
the Base Contour at 0 and the Z Factor at 1, then specify where to save the output shapefile in 
your working directory and what to call it (e.g. Provo_25cm_Contours.shp). 

2. This will produce a vector shapefile of type polyline, where the polylines represent the individual 
contours: 

http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=3579&pid=3577&topicname=Creating_contours�
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=3579&pid=3577&topicname=Creating_contours�
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3. If you wish to check the elevation of a particular contour use the Identify tool  to see its 
elevation. If you want to label the contours, right click on the contour layer and in the Properties 
Dialog go to the Labels tab and adjust the settings. 

 

 

SLOPE ANALYSIS (OPTIONAL) 

A slope analysis is a useful tool for showing local6

1. To perform a slope analysis of the DEM, go to 3D Analyst -> Surface Analysis -> Slope 
Analysis: 

 slopes.  

                                                                 

6 Since local slopes are calculated on a cell-by-cell basis relative to neighboring cells, they are not a good 
approximation of reach slopes. 
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As with the other commands, specify the Input Surface as the Provo_DEM, choose whether you 
prefer to see slope values in degrees or percent, keep the Z Factor at 1, keep the Output 
Cell Size the same as your input surface (1 meter in our example), and specify where to save the 
output raster. Upon clicking OK you will see something like the below: 

 

 

Notice that the banks pop out very clearly in red. 
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DERIVE WATER DEPTHS (OPTIONAL) 

A map of water depth (at time of survey) can be very helpful for context, visualization, instream habitat 
mapping, as well as depth validation of hydraulic model results. If you have a DEM of bathymetry, and a 
water surface edge survey, you can derive water depths. 

1. First import the water surface edge survey st_reach_wse_nez.csv (refer to instructions 
above if you need help). 

 
The points should appear as an outline of the waters edge. 

2. Next create a shapefile7

3. Next derive a water surface TIN using the waters edge polygon as a hard clip boundary and the 
st_reach_wse_nez.csv dataset.  

 and edit it to draw a polygon around the waters edge survey. 

4. Next, convert  your water surface TIN to a water surface DEM (using the Tin to Raster tool). 

                                                                 

7 Refer back to instructions on creating a shapefile if you need help (i.e. Create Feature Class tool). 



ICRRR Short Course Part II – DEM Exercise 

 
26 of 43 

 
Your water surface raster should look something like the above. 

5. To derive a water depth, we simply need to subtract the DEM bathymetry elevations from the 
water surface elevations. To do this, we can use the Raster Calculator found in the Spatial 
Analyst Toolbar: 

 
In our example, this produces a raster with both negative and positive values in the 
Calculation layer.  

6. The negative values need to be filtered out from the Calculation. We can use the Raster 
Calculator to do this with a logical operator: 
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By checking for all cells in which the [Calculation] > 0, the raster calculator will return a 
Calculation2 layer with 0s where the argument is false (i.e. the cells we want to remove) 
and 1s where the argument is true. 
 

7. Wecan  then use a Reclassify command in the Spatial Analyst toolbar menu to turn the zeros 
into NoData (thereby eliminating them): 

 
For 0 change the New Values to NoData, and for 1 leave the New Values as 1 (or delete 
entry). Click OK to evaluate. 

8. We can then use the Raster Calculator one last time to get our water depth layer 
(Calculation3) by multiplying our Reclassified Layer by the original Calculation layer. 

9. We can now make this layer permanent by right clicking on it and saving it in our working 
directory as Provo_WD, for example. If we change the display properties of the layer to a blue 
color ramp, we now have a nice water depth map. 
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RIVER BATHYMETRY TOOLKIT (OPTIONAL) 

The River Bathymetry Toolkit is a free plug-in that can be installed for doing a number of common tasks to 
DEMs of rivers, which include bathymetry (under water elevations). These tasks include, detrending the 
DEM, deriving a bankfull stage, deriving channel thawlegs, channel centerlines, extracting longitudinal 
profiles, extracting cross sections and hydraulic geometry. Here we highlight the first  two of the tools 
(see RBT Documentation for details, example data, tutorials and instructions).  

Detrending of DEMs is the process of removing the valley slope trend in the DEM such that elevations 
relative to the channel itself our displayed. This helps bring out the topography of the river and highlight 
pools and riffles and relative bank elevations. Once the RBT toolbar is installed 

, you can access the Detrend 
command from the Bankfull/Centerline menu: 
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There are a number of parameters (see RBT Documentation), but if you specify your DEM (Provo_DEM 
for our example), you can click OK, wait patiently and you will ultimately derive a detrended DEM: 

 

As compared with the regular DEM, this detrended DEM does a nice job of highlighting the pools, bars 
and floodplain. 

In RBT, if you have a detrended DEM, you can use it to derive approximations of flood inundation paterns 
with their Bankfull Tool. The Bankfull Tool shows you a distribution of detrended elevations and has an 
interactive slider bar you can adjust and see how inundation patterns adjust accordingly (in RBT, they use 
this to establish an approximate bank full elevation). 
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See below for more information on RBT. 

MORE INFORMATION 

For more information on some of the tools described above as well as other tools for working with DEMs 
in rivers, you may find some of the following resources useful: 

• For ArcGIS 3D 
Analyst: http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=An_overview_of_th
e_3D_Analyst_toolbox  

• For River Bathymetry Toolkit, go 
to: http://www.fs.fed.us/rm/boise/AWAE/projects/river_bathymetry_toolkit.shtml and refer to 
McKean et al. (2009). 

• For HEC-Geo-RAS: (http://www.hec.usace.army.mil/software/hec-ras/hec-georas.html) 
• For morphological sediment budgeting using repeat topographic surveys, see the DoD 

Uncertainty Analysis Software at: http://www.joewheaton.org/Home/research/software/dod-
uncertainty-analysis-software  and refer to Wheaton et al. (2010). 

http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=An_overview_of_the_3D_Analyst_toolbox�
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=An_overview_of_the_3D_Analyst_toolbox�
http://www.fs.fed.us/rm/boise/AWAE/projects/river_bathymetry_toolkit.shtml�
http://www.hec.usace.army.mil/software/hec-ras/hec-georas.html�
http://www.joewheaton.org/Home/research/software/dod-uncertainty-analysis-software�
http://www.joewheaton.org/Home/research/software/dod-uncertainty-analysis-software�
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PART II - CREATE DESIGN DEM 

A design DEM is one that shows the topography of the design merged with the existing topography. A 
design DEM is ultimately a digital version of a grading plan that might be handed to a contractor. Design 
DEMs are useful for doing earthwork calculations to estimate volumes of cut and fill and assess whether 
or not there is a balance or whether or not material will need to be imported or exported. Depending on 
the nature of the grading, some contractors can use a design DEM for machine control construction (with 
survey grade GPS or total stations) to control graders, scrapers and dozers. Design DEMs can also be used 
to compare against as-built surveys to assess how well the constructed project matches the design 
project. Finally, design DEMs are also useful to act as topographic boundary conditions in hydraulic and/or 
morphodynamic models to test design conditions and/or test specific design hypotheses.  

In this exercise, we will very briefly go through one workflow using GIS to create a simple grading plan and 
covert it to a design DEM for potential use in the 

CREATE GRADING PLAN LAYERS 

The first step to create a grading plan is to draw some contours in a feature class or shapefile of type 
polyline. 

1. Navigate to the ArcToolBox   and down to Data Management Tools -> Feature Class -> 
Create Feature Class:  

 
Fill out the dialog as with before (see Modify TIN), but this time make sure that the Geometry 
Type is POLYLINE and that Has Z is ENABLED. This will allow you to assign contour 
elevations to the polylines and make them three dimensional.  
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2. To easily assign elevations to each vertice in the polylines, we will use the Current Z tool8

 

. To do 
this, right-click on a blank part of the toolbar in ArcGIS and switch to the Commands tab and 
navigate to the Editor commands under Categories and locate the Current Z command. Drag the 
command up on to the Editor toolbar as shown below:  

This puts the  command in the toolbar and allows you to specify an 
elevation in an edit session for any feature class that has Z values enabled. 

 

MAKE GRADING PLAN WITH CONTOURS & FINISH GRADE POINTS 

CONTOURS 

In this example we will grade in (with cutting) a side channel. Decide the area you wish to regrade, locate 

the contours and if necessary use the Identify tool  to check the contour elevations of existing 
contours. Your grading plan contours should almost always start at an existing contour and finish further 
along the same elevation contour. The only exception to this is for peaks or troughs, where you can use a 
closed circle contour inside the boundaries of neighboring grading contours. It is easy to accidently 
connect a grading contour to two different elevation contours. Such an error will create an abrupt step in 
your topography as opposed to smooth transitions.  

To draw contours, you simply need to Start Editing for the target layer with your contours 

(Provo_Design01_25cm_Contours in our case). Then use the sketch tool  to draw your 
contours, baring in mind the rules outlined above. When you start your contour, make sure you have 

                                                                 

8  See http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=4764&pid=4762&topicname=Defining_z-
values_for_features for more information on defining z-values for features. 

http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=4764&pid=4762&topicname=Defining_z-values_for_features�
http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?id=4764&pid=4762&topicname=Defining_z-values_for_features�
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specified the elevations to use in the Current Z box . The example below shows a 
grading plan depicting a side channel to be cut into the inside bend (using red contours). The closed red 
circles represent two pools in the side channel. The side channel bifurcates at the downstream end, such 
that the side channel rejoins the main channel at two places.  

 

To make sure the contour you drew has the correct elevation values, you can check or modify its 

elevations by clicking the Edit Tool  and then double-click the contour with the z-values you want to 
check or edit. Once selected (it will be a different color and vertices will show), use the Sketch 

Properties button  on the editor toolbar to make sure the Z values are what you expect them to be: 
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When you’re happy with the contours, Stop Editing and save your changes.  

FINISH GRADE POINTS 

Creating finish grade points is especially useful for Design DEMs that will be used in hydraulic modeling to 
define critical low points and crest elevations that have a large influence on controlling hydraulic patterns 
and topographically steering the flow. Because the contours can only specify the topography to within a 
plus or minus range of the contour interval, spot elevations (or finish grade points) can be used to fill in 
between. 

1. Again, create a feature class for the new points:  

 
Fill out the dialog as with before (see Modify TIN), but this time make sure that the Geometry 
Type is POINT and that Has Z is ENABLED. This will allow you to assign point elevations to 
and  make them three dimensional.9

2. To create finish grade points, use the sketch tool and click where you want points. There are 
various ways to specify your finish elevations. I suggest using the current Z tool

  

                                                                 

9 NOTE: If you want to export these points out to a *.dbf table and use the points elsewhere, you may 
wish to also create an Elevation field and manually populate it with elevation values as you create your 
points. This is not necessary for modeling within ArcGIS as the 3D z value is stored in the Geometry of the 
point, but that information is not as easy to extract and export. 
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in the editor toolbar and change the values as you go. Alternatively, 

you can use the Edit Tool  and double-click on the point you wish to modify,  and use the 

Sketch Properties button  on the editor toolbar to then edit the Z value. The points should 
generally be in between the contour intervals (otherwise, just draw another contour). Points 
should be placed to define critical crest elevations and low points: 

 
3. Once you’re done with creating points, stop the edit session and save the changes. Remember, 

saving the Map Document does not actually save edits. Only saving edits from the Editor menu 
saves edits to a feature class or shape file.  
 

 

DELINEATE GRADING BOUNDARIES 

After you’ve created your grading plan with contours and spot elevations, we want to create a new DEM 
of the study site that includes the original elevations everywhere no grading will take place, and the new 
elevations where you have specified them. One way to do this is by using a polygon grading boundary. 

1. First we need to create a polygon shape file: 
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Fill out the dialog as with before (see Modify TIN), but this time make sure that the Geometry 
Type is POLYGON.  

2. Draw the boundary around the edge of your contours:  

 
The polygon should not extend too far into the non-graded area as you want to be able to use as 
many of those original points as possible. 
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GET TOPOGRAPHIC DATA FOR DESIGN DEM ALL TOGETHER 

Now we want to use all of the original survey points outside the grading polygon, and use only the 
contours and the design points inside the polygon. To build this file requires multiple steps.  

1. First, use the Erase command in the ArcToolbox -> Analysis Tools -> Overlay -> Erase:  

 
Select the original topography point data (st_reach_topo_nez) for the Input Features, 
select the Grading_Bndy for the Erase Features, and specify the Output Feature Class as a name 
you will recognize in your working directory (e.g. Provo_Design01_TIN_Points.shp). 
The resulting shapefile will have all the original points outside the graded area: 

 
2. Next we will use some basic editing commands to copy the points from the 

Provo_Design01_Points layer to the Provo_Design01_TIN_Points layer. Start an 
edit session for the Provo_Design01_Points layer.  

3. Open the Attribute Table for  Provo_Design01_Points layer and select all the points: 
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After you’ve selected all the points, copy them (e.g. Edit -> Copy). Now turn off the 
Provo_Design01_Points layer in the Display dock and close the attribute table. 

4. Next, open the attribute table for Provo_Design01_TIN_Points layer and change Target 
in the editor toolbar to this. Also make sure that the Task: is set to Create New Feature. Now you 
can paste (using Edit -> Paste or control V) the points from the Provo_Design01_Points 
layer into the Provo_Design01_TIN_Points layer: 
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Notice that the copied points all have 0 listed for the northing, easting and elevation. The point 
coordinates are correctly preserved in the Shape geometry for the feature class. However, the 
attribute fields are not populated.  

5. OPTIONAL -> (skip to 6 if not exporting points). If you plan on exporting your points for use 
elsewhere, you will want to populate the northing, easting and elevation values. The Northing 
and Easting columns can be recalculated by simply highlighting the top of the column, right-
clicking and selecting the Calculate Geometry command (choose X for Easting, Y for Northing). 
However, the elevation field has to manually edited. 

6. Stop the Edit session and save your changes. 
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BUILD NEW DESIGN DEM 

1. To build the design DEM, we will create a TIN (refer to previous Create TIN from Data section for 
more detailed instructions). Bring up the Create TIN… dialog:  

 

This time we will use three inputs:  

• Survey Bndy with <None> as the height source, and triangulate as hard clip 
• Provo_Design01_TIN_Points with <Elevation> as the height source and triangulate as 

Mass Points 
• Provo_Design01_25cm_Conturs with <Feature Z Values> as the height source and 

triangulate as <hard line> 

Save this as Provo_TIN_Design in your working directory and click OK.  
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Notice the side channel now shows up in the TIN. 

2. As with before, it may be useful to visualize this with 25 cm contours, and convert it to a DEM 
and Hillshade.  

 
Above, the Design DEM contours are shown in black and the original design polygon contours are 
shown in red. You can iterate on the specification of individual points to improve the match or 
accept the result as is. Once you are satisfied, you are done. Congratulations. 
 
It should be noted that this process is straightforward to implement to compare multiple design 
scenarios. 
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EXPORTING POINT DATA (OPTIONAL) 

If you wish to export the point data for use externally, you can easily export the original point data and 
design points to a *.dbf file using the Export tool from the attribute table of 
Provo_Design01_TIN_Points layer. However, you need to export the design contours as 
well. Some programs will accept a shape file. You can also use the File Management Conversion tools 
to convert this to various CAD formats (e.g. *.DXF file).  However, if you need to get the points off here 
is a simple workflow that extracts the point values from the DEM at the contour vertices: 

 

1. In ArcToolbox, go to Data Management Tools -> Features -> Feature Vertices To Points: 

 
 
Specify the Provo_Design01_25cm_Contours layer as your Input Features, specify 
a Output Feature Class to save the points to, and then select ALL for Point Type. 
 

2. Next, navigate in ArcToolbox to Spatial Analyst Tools -> Extraction -> Extract Values to 
Points: 
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This will create a point file with an elevation field from the DEM.  

3. You will need to create two new fields in the shapefile for the Norhting and Easting and populate 
them with the Calculate Geometry tool to get those coordinates. Then, you can export the points 
to a *.dbf file and use them as described previously. 
 

SUMMARY 

This tutorial walked you through two simple tasks: building a DEM from raw topographic data, and 
building a desigin DEM using your own imagination. With the screen shots, step-by-step instructions, and 
optional sections, this 44 page document could give the impression that this is a lengthy and tedious task. 
In reality, the first task typically takes 5-30 minutes, and the second task is a simple workflow, in which 
the amount of time required depends on the complexity and scope of your design.  

References were provided throughout and a few papers on RBT and DoD work are listed below. If you get 
really stuck, feel free to contact me at Joe.Wheaton@usu.edu and I’ll attempt to help you. 
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